Select Page

I signed up with 1And1 a little while back, to set up a website for a friend of mine. He needed a WordPress site for a family blog. I haven’t used WP much, just played around with it a bit to familiarize myself with something new and interesting. To make a long story short, I got him all set up with some minor issues that were quickly resolved, then left him to it with a little training.

Recently I set about getting my own site up with WP (something I have been meaning to do for quite some time, but have pushed it aside for work or building/updating friends’ and family’s sites), and started some more playing around. One of the first things I found was that 1And1 doesn’t play well with the auto-update feature. WP hangs at the update screening stating that it is downloading the package, then…nothing.

I tried tweaking permissions (1And1 is a bit odd on its permissions at times), but to no avail. So, I went looking for an answer with my trusty search engine. Lo and Behold, an answer! Seek and Ye shall find! On WordPress.org no less. Here, I found the answer for which I sought. If you need more info on it just click on the link below that article for bassmadrigal’s entry.

The long and short of it is this;

Edit the .htaccess file in your WP’s root directory and add the following line:

AddType x-mapp-php5 .php

This tells Apache to parse all .php files as php5. That’s it. Problem solved. Update WP and good to go.